First implementation of socket stream classes derived
[sockstream.git] / test / Makefile.am
index 6396368..24b5c6c 100644 (file)
@@ -1,11 +1,23 @@
-check_PROGRAMS = iptest revd
+check_PROGRAMS = iptest revd intest outtest http_get
 
 iptest_SOURCES = iptest.cpp
 iptest_CPPFLAGS = -I$(top_srcdir)/include
 iptest_LDADD = $(top_builddir)/src/libsockstream.la
 
+http_get_SOURCES = iptest.cpp
+http_get_CPPFLAGS = -I$(top_srcdir)/include
+http_get_LDADD = $(top_builddir)/src/libsockstream.la
+
 revd_SOURCES = revd.cpp
 revd_CPPFLAGS = -I$(top_srcdir)/include
 revd_LDADD = $(top_builddir)/src/libsockstream.la
 
-TESTS = iptest revd
+intest_SOURCES = intest.cpp
+intest_CPPFLAGS = -I$(top_srcdir)/include
+intest_LDADD = $(top_builddir)/src/libsockstream.la
+
+outtest_SOURCES = outtest.cpp
+outtest_CPPFLAGS = -I$(top_srcdir)/include
+outtest_LDADD = $(top_builddir)/src/libsockstream.la
+
+TESTS = iptest stream